July 19, 2018

OSPFv3 Virtual Link Configuration

(Last Updated On: 3rd July 2017)

In this article, you find many use cases for OSPF virtual links when and how they are used.

We will dive into OSPFv3 for this example.

All areas in an OSPF autonomous system must be physically connected to the backbone area (area 0). In some cases where this physical connection is not possible, Virtual-Links are used in cases like this where you have disconnected OSPF “areas”  as you can see in our topology we have the following areas 0, 23, 34. From Cisco documentation, we can see we use the area “area-id” virtual-link “router-id” command in order to configure a virtual link, where the area-id is the area ID assigned to the transit area (this can be either a valid IP address or a decimal value), and where router-id is the router ID associated with the virtual link neighbor.

Configurations

This document uses these configurations:

Router –  RTR1

Router – RTR2

Router – RTR3

Router – RTR4

————————————————————————–

hostname RTR1

!

ipv6 unicast-routing

ipv6 cef

!

interface Loopback0

no ip address

ipv6 address FE01:1::1/64

ipv6 enable

ipv6 ospf 10 area 0

!

interface Ethernet0/1

no ip address

ipv6 address 2011:8:8:1::1/64

ipv6 enable

ipv6 ospf 10 area 0

no shut

!

ipv6 router ospf 10

router-id 1.1.1.1

log-adjacency-changes

————————————————————————–

hostname RTR2

!

ipv6 unicast-routing

ipv6 cef

!

interface Loopback0

no ip address

ipv6 address FE01:2::2/64

ipv6 enable

ipv6 ospf 10 area 0

!

interface Ethernet0/1

no ip address

ipv6 address 2011:8:8:1::2/64

ipv6 enable

ipv6 ospf 10 area 0

no shut

!

interface Serial1/0

no ip address

ipv6 address 2011:8:8:2::2/64

ipv6 enable

ipv6 ospf 10 area 23

serial restart-delay 0

clock rate 64000

no shut

!

ipv6 router ospf 10

router-id 2.2.2.2

log-adjacency-changes

————————————————————————–

hostname RTR3

!

ipv6 unicast-routing

ipv6 cef

!

interface Loopback0

no ip address

ipv6 address FE01:3::3/64

ipv6 enable

ipv6 ospf 10 area 23

no shut

!

interface Ethernet0/1

no ip address

ipv6 address 2011:8:8:3::3/64

ipv6 enable

ipv6 ospf 10 area 34

no shut

!

interface Serial1/0

no ip address

ipv6 address 2011:8:8:2::3/64

ipv6 enable

ipv6 ospf 10 area 23

serial restart-delay 0

no shut

!

ipv6 router ospf 10

router-id 3.3.3.3

log-adjacency-changes

————————————————————————–

hostname RTR4

!

ipv6 unicast-routing

ipv6 cef

!

interface Loopback0

no ip address

ipv6 address FE01:4::4/64

ipv6 enable

ipv6 ospf 10 area 34

!

interface Ethernet0/1

no ip address

ipv6 address 2011:8:8:3::4/64

ipv6 enable

ipv6 ospf 10 area 34

no shut

!

ipv6 router ospf 10

router-id 4.4.4.4

log-adjacency-changes

————————————————————————–

Verify

We can use the following commands to verify the configuration:

First, let us verify that we can not ping RTR4, We can see that we cannot successfully ping all the way through.

We see the farthest we can reach via our routing table is to RTR3 > 2011:8:8:2::3

Neighborships before Virtual links.

By adding the following commands to RTR2 we can start our virtual link tunnel.  Remember when using virtual links we are using the router that is connected to area 0 and the router that is connected to our disconnected area 34.

The same thing to RTR3 respectively.

Now if we take a look at OSPFv3 Neighbors we see that we have a new neighbor of 2.2.2.2

Now let verify our routing table of RTR4 and see our new routes!

Know we can see that we have reachability to RTR1 via our Ethernet 0/1 for the address of Fe01:1::1.

Lets pings this address for confirmation!

There we go! I hope you enjoyed this article.

Previous «
Next »

Networking and things of this nature...

2 Comments

  1. Nice post! This is a very good topic for those perusing the CCNP R&S certification and in general.

  2. Agreed! using OSPFV3 in this example is a good way to cover all your tracks when perusing the CCNP R&S.

Leave a Reply

Subscribe to SYNACK via Email

%d bloggers like this: